Troubleshooting Bicycle Dynohub and LED light conflict.

I bought a Shimano bicycle Hub dynamo and a Raleigh RSP2 LED bicycle headlight. When working together they are very impressive, casting a beam that makes night cycling much easier with an impressive ability to see and be seen. However from the first there were problems, such as the light occasionally stopping working and the on/off switch never working at all. Eventually the system stopped entirely. As I had bought a second headlight, originally for another bicycle, I fitted that and sought to troubleshoot the first.

The light has no meaningful instructions, despite having two wires (of different colours) and two (unmarked) terminals. This had made the initial installation difficult, especially as I also wired a rear light that did have polarity marked on its terminals. The rear light turned out not to be the problem.

To put the conclusion first : the Shimano hub connects one side of its AC output to the axle and hence the bicycle frame. The RSP light connects one side of its DC circuit to its mounting bracket and hence (usually) the frame. It is almost certain that any installation of these components will conflict. Depending on the specific wiring the light may however appear fine, although it flickers more at slow speed than necessary. It will however be being operated without current limiting and presumably be likely to fail prematurely. More details are below, but it is disappointing that this problem is not well publicised on bicycle fora.

The light seems to be a sealed unit and eventually I had to destroy it to open it and inspect the circuit. Investigations before I opened it gave no real clue as to the specific wires/terminals : in fact, all seemed to be shorted together according to my multimeter.

On disassembly the positions became clear. The external wires and the terminals are directly connected in pairs (specifically the black/white wire connects to the left-hand terminal when viewed from the rear, and the white wire to the other). Internally the wires are connected by a Transient Voltage Suppressor (P6KE9.1CA) i.e. it clips the AC to a nominal 9.1V peak value. This seemed to be faulty, conducting at all voltages, hence creating the apparent short between terminals seen by my multimeter. I suspect this to be the fault that finally caused my lamp to fail, but not the primary problem as discussed below.

The black/white wire is only distinguished from the white wire in that the latter is internally connected to the on/off switch. This is consistent with the lack of exterior markings on the terminals, although somewhat inconsistent with using different colour wires at all. It should not really matter which wire is which since they are connected as the AC inputs to a bridge rectifier. However it does actually matter in the fault condition described below, because the switch is attached to one particular wire.

The DC side of the circuit consists of two resistors in parallel, the pair then in series with the LED. In principle this is a simple circuit, typical for a LED, of a current limiting resistor on a DC circuit, with the bridge rectifier converting the AC to DC and letting the LED illuminate on both the positive and negative AC cycles. However the positive side of the LED (in fact the whole metal plate on which it is mounted) is in contact with an aluminium spar that forms the backbone of the light and presents a threaded hole for attachment to the bracket and hence the bicycle. This is likely to lead to electrical contact with the bicycle frame, especially as a metal bracket is supplied – assembled and connected to this spar. This spar may well also form a heatsink as it is in electrical and thermal contact with the LED backplate and is a piece of costly aluminium used where plastic would have been structurally adequate, so removing it may be unwise.

The electrical contact to the frame is the problem. Unlike some hub dynamos, Shimano hub dynamos are also electrically connected to the bicycle frame and for this light this shorts one AC input with the DC positive line. This is an especial problem as it circumvents the current limiting resistors used with the LED. There are now effectively two cases depending on whether it is the white or the black/white wire that is connected to the frame (recall there are no instructions). If the white wire is connected to the frame, then the on/off switch will work as expected and the light will appear to work fine. However what is actually happening is that the LED is only active on half the cycles and is working without the current limiting resistor. On the other half cycles, current still flows through a pair of diodes but the LED is out of the circuit. In the other case where the black/white wire is the one connected to the frame, the situation will be the same except that the on/off switch will not work (the light will always be connected somehow). This latter case matches exactly the symptoms I saw, although I did not realise the low speed flickering was worse than the design intent (given an AC supply, with no smoothing, some flicker is inevitable).

Solution

As the light’s case does not appear to be designed to open without destroying the headlight, an external solution is preferable. For attaching the light, the spar has a threaded M4 hole in a block with a local diameter around 8mm, i.e. could be drilled out to 5mm or 6mm diameter and an insulating sleeve placed around the original M4 bolt. A simpler technique without risking voiding the warranty is to use an insulating bolt (e.g. nylon) in the original hole (M4 at 25mm long will suit). Both of these techniques should be possible without opening the case – I have only tried the latter. The net effect is to insulate the light’s DC circuit from the bicycle frame and hence avoid a short to the AC circuit.

Experiments

To probe whether the above analysis was correct, I used a MCP3008 Analogue to Digital Converter connected to a Raspberry Pi Nano to achieve around a 1 kHz sampling rate of both voltage and current, the latter using a ACS712-based sensor to convert current to voltage. The results are as follows, and confirm the above analysis as far as I can tell :results

Wider applicability

I have only tested one light from one manufacturer, and cannot tell if other lights are affected. However the fact that the symptoms were not clear cut could mean the problem is widespread yet unreported and many people are operating lights with greater flickering, without current limitation and with the unknown risk of premature failure.

Summary

When using a hub dynamo that is not electrically insulated from the bicycle frame, the RSP2 light I bought needs to be installed carefully (with changes to its supplied components) to avoid appearing to work while actually operating out of specification, adding extra drag and perhaps being damaged. The lack of any manufacturer instructions (let alone ones covering this issue) make it highly likely the light will be installed wrongly. The problem might be widespread. This cost me at least one LED headlight. I hope the article helps you avoid that.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s